Prerequisites

This page lists the prerequisites required to run Git for Windows.

Windows version

As of Git for Windows v2.10.1, Windows Vista or later are required. The last version of Git for Windows to support Windows XP and Windows Server 2003 is v2.10.0.

Why?

Parts of Git are implemented in shell script, and Git for Windows runs those scripts via MSYS2's POSIX emulation layer, which in turn is based on the Cygwin POSIX emulation layer. Seeing as Windows XP and Windows Server 2003 are years past their official end of life, the Cygwin project ended their Herculean efforts to support those Windows versions.